I just set up a win xp virtual box (remember to enable 3D acceleration) and to test out globe on windows. here what I did:
Get OSGeo4W installer and run it
Choose advanced install
Select qgis-dev, osgearth-bin, osg-bin from the desktop packages
Select osgeart-dev, osg-dev from libs
Run
Open Qgis, activate the globe plugin in plugin manager, click on the globe button and post here your success stories 😉


11 Comments

James · 2011-11-16 at 12:52

Hi
I followed your instructions carefully, and didn’t receive an error message during the installation, yet cannot see the Globe plugin in QGIS (1.7.1)
Any ideas! James

    marco · 2011-11-22 at 11:11

    Hi James, I’ve been away for a couple of month. sorry for the late answer, did you activate the plugin in the plugin manager? it is not on by default.
    ciao

Knut Karlsen · 2011-12-06 at 13:13

Hi again,
I did get it to work (just had to lok in the manage plugins list), but it seemed very unstable at the moment. It might be my installation (i got dev and 1.7.2 runnig on same windows machine) and its paths, but I’m not sure how qgis-dev should correctly be initialised with paths etc.
I’ll get back to you if I can get it to work any better.

sinned · 2011-12-27 at 21:29

hi,
i cant see this “qgis-dev, osgearth-bin, osg-bin from the desktop packages” after Advance Install. why?
thanks

Sebastian · 2012-01-17 at 12:57

I followed the instructions, the installation succeded. I could enable the plugin.
When I click on the globe-icon, QGIS crashes. After restarting QGIS, the globe-window is present, but without any globe.
Did anyone get it running on a clean windows-installation?

maxion · 2012-05-15 at 19:46

same issue. How can I see the globe?

    marco · 2012-05-15 at 19:49

    mmm I’ve seen this some random times, try enlarging the globe window by dragging its side.

maxion · 2012-05-15 at 19:58

this works, but still no globe

maxion · 2012-05-15 at 20:00

where is the globe saved at? where does the data for the globe come from?

maxion · 2012-05-15 at 20:09

This is an plugin-error when I start Qgis1.8 Lisbona, trying to get the globe working. Has it anything to do with it?
Konnte Erweiterung GoogleLayers nicht laden wegen eines Fehler beim Aufruf seiner initGui()-Methode
Traceback (most recent call last):
File “C:/OSGeo4W/apps/qgis-dev/./pythonqgisutils.py”, line 173, in startPlugin
plugins[packageName].initGui()
File “C:UsersMaxion/.qgis/python/pluginsGoogleLayersGoogleLayers.py”, line 33, in initGui
self.sessionid = gmaps.get_sessionid()
File “C:UsersMaxion/.qgis/python/pluginsGoogleLayersgmaps.py”, line 21, in get_sessionid
sessionid = t.strftime(“%d%m%Y_%H%M%S%s”)
ValueError: Invalid format string
Python-Version:
2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]
QGIS-Version:
1.8.0-Lisboa Lisboa, a1255fc
Python-Pfad: [‘C:/OSGeo4W/apps/qgis-dev/./python’, ‘C:\Users\Maxion/.qgis/python’, ‘C:\Users\Maxion/.qgis/python/plugins’, ‘C:/OSGeo4W/apps/qgis-dev/./python/plugins’, ‘C:\OSGeo4W\bin\python27.zip’, ‘C:\OSGeo4W\apps\Python27\DLLs’, ‘C:\OSGeo4W\apps\Python27\lib’, ‘C:\OSGeo4W\apps\Python27\lib\plat-win’, ‘C:\OSGeo4W\apps\Python27\lib\lib-tk’, ‘C:\OSGeo4W\apps\qgis-dev\bin’, ‘C:\OSGeo4W\apps\Python27’, ‘C:\OSGeo4W\apps\Python27\lib\site-packages’, ‘C:\OSGeo4W\apps\Python27\lib\site-packages\PIL’, ‘C:\OSGeo4W\apps\Python27\lib\site-packages\win32’, ‘C:\OSGeo4W\apps\Python27\lib\site-packages\win32\lib’, ‘C:\OSGeo4W\apps\Python27\lib\site-packages\Pythonwin’, ‘C:\OSGeo4W\apps\Python27\lib\site-packages\wx-2.8-msw-unicode’]

marco · 2012-05-15 at 20:12

no, globe is c++ should have nothing to do with python

Leave a Reply to maxion Cancel reply

%d bloggers like this: