QField for Android 5

It’s done, QField runs on any android from 4.0.3 (ICS) with a seamless installing experience. We suggest using at least Android 4.3

Tagged with: , , ,
Posted in Featured, QField